Путь к Java для Eclipse

Когда у вас на компьютере зоопарк из разных версий Java, то зачастую Eclipse будет запускаться с Java, которая была установлена последней. У меня, например, сложилась такая ситуация, что последней версией было JDK 9.0.1, но Eclipse у меня старый. Он, разумеется, вполне запускается и на новой версии Java, но в Java 9 было достаточно много изменений. Например, там были удалены “tools.jar” и “rt.jar”, а они используются некоторыми плагинами Maven-а.

Чтобы мой Eclipse снова заработал как надо, мне пришлось в “eclipse.ini” прописать аргумент -vm, который указывает путь к Java, с которой нужно запускать IDE.

В файле “eclipse.ini” важен порядок! Нужно обязательно указывать  -vm  до -vmargs!

В результате мой файл стал выглядеть вот так (у меня сборка Spring Tool Suite, там этот файл называется “STS.ini”, но по сути это тот же Eclipse, но с предустановленными плагинами):

Надеюсь, что кому-нибудь эта статейка окажется полезной…


Поделиться:
1 Звезда2 Звезды3 Звезды4 Звезды5 Звезд (Пока оценок нет)
Загрузка...

Добавить комментарий

Ваш e-mail не будет опубликован.

*